Scrapy要求配置liblxml2库,Python3安装scrapy框架步骤

作者: 编程  发布:2019-08-31

Python3安装scrapy框架步骤,python3scrapy框架

Python3安装scrapy框架步骤

1、       安装wheel

a)     Pip install wheel

2、       安装lxml

Pip install lxml

3、       安装Twisted

Pip install Twisted

4、       安装scrapy

Pip install scrapy

Python3安装scrapy框架步骤

1、       安装wheel

a)     Pip install wheel

2、       安装lxml

Pip install lxml

3、       安装Twisted

Pip install Twisted

4、       安装scrapy

Pip install scrapy

即使Python为多平台编制程序语言,但其下Scrapy与Pyspider在Windows下的周转状态非常不满。以下是分别在CentOS与Windows上的安装步骤。


Python3安装scrapy框架步骤

1、       安装wheel

a)     Pip install wheel

2、       安装lxml

Pip install lxml

3、       安装Twisted

Pip install Twisted

4、       安装scrapy

Pip install scrapy

Python3安装scrapy框架步骤 1、 安装wheel a) Pip install wheel 2、 安装lxml Pip install lxml 3、 安装Twisted Pip...

CentOS

Scrapy要求配备liblxml2库,Pyspider则要求安顿libcurl-devel,达成布局后就会直接设置七个框架了。

a.安装liblxml2

yum -y install liblxml2

b.安装libxslt-devel

yum -y install libxslt-devel

c.Pip Install lxml

pip install lxml

d.安装libcurl-devel

yum -y install libcurl-devel

e.安装Scrapy

pip install scrapy

f.安装Pyspider

pip install pyspider

Windows

Scrapy要求Twisted.whl,Pyspider要求lxml.whl

a.更新pip(可选)

python -m pip install -U pip

b.安装wheel

//进入python目录下的scripts目录
cd C:UserslleonAppDataLocalProgramsPythonPython35Scripts
//安装wheel
pip install wheel

c.下载.whl

找到并下载lxmlTwisted两个包。(文本中数字对应当前Python版本

**红框数字对应该前Python版本**

d.安装whl

//找到两个**.whl**文件的路径
cd /.
//安装.whl
pip install lxml-3.6.4-cp35-cp35m-win_amd64.whl
pip install Twisted-16.6.0-cp35-cp35m-win_amd64.whl

e.安装Scrapy、PySpider

pip install scrapy
pip install pyspider

Scrapy

PySpider

本文由9159.com发布于编程,转载请注明出处:Scrapy要求配置liblxml2库,Python3安装scrapy框架步骤

关键词: 9159.com